Tarvis's Guide For Windows 8 Users

Post 3D Acceleration, Network Configuration, 64-Bit Installation, DirectPlay Problems, etc.
LSF_Nick
Junior Member
Posts: 82
Joined: Mon Jan 02, 2006 2:00 am

Tarvis's Guide For Windows 8 Users

Postby LSF_Nick » Sun Aug 03, 2014 3:14 pm

Playing on Windows 8

This is a guide for playing on Windows 8! If you're using it, you should try all the steps in this guide for the best possible experience, and it should solve all your issues.


I have made a batch script that will do all of this for you, in 1 easy step! Get it here.[www.mediafire.com]

Extract everything to the game's folder and run WINDOWS_8_PATCH.BAT. That's it!
Don't try this if you're on Windows 7. The fixes will NOT work for it, and will only make things worse.


Q: "Nothing happens when I launch the game!"
or
Q: "The game won't launch because it says I need to have 256 colors!"
A: Go to the game's folder, right click JK.EXE, go to Properties, then the Compatability tab, and enable Windows XP (Service Pack 2) mode. You can even unset it later if you want, and it'll still work!


Q: "The game menus run in a window! Can I fix this?"
A: NOTE: Currently, the following only works if you run the game directly from its folder, and not from Steam.

On Windows XP and 7, Jedi Knight had many issues with the paletted fullscreen menu, so the Steam release forces the -windowgui command line option. But, it turns out that Windows 8 handles it just fine, so you can get it back if you want to!

[s]To do this, you need to find the original unpatched JK.EXE on the internet. I don't own the Steam version myself so I don't know if you'll need to remove the CD checking again or not, but I don't think you'll have to.

You can get it using this tool (it connects to LucasArts' own FTP, so it is legal)[www.jkhub.net]. It MUST be ran as an Administrator or it will crash!

Once it finishes it will open up a folder containing the original JK.EXEs. Copy the jk.Unofficial.Patch EXE and JK-Extension.dll to your Jedi Knight folder, rename the original JK.EXE to something else and rename the new Unofficial Patch one to JK.EXE.[/s]

NOTE: Steam seems to force the command line option anyways. I'll think of a solution. You can run JK.EXE direct from the game folder to get the fullscreen menu for now.


Q: "The game shows as all black, but I can see the HUD!"
A: Go to the game's Display options and UNtick Use Hardware Acceleration.

The D3D mode doesn't work with Windows 8 yet. In the future the community might have a fix for it, but right now software mode is the way you have to play. It doesn't look too bad, though, you'll just have a few less colors (but you'll get texture lighting effects that the D3D mode didn't have!)


Q: "The game seems to run too fast! (Gun sways at lightspeed when moving)"
A: UNtick "Backbuffer In System Memory" in Jedi Knight's display options. This isn't quite enough however, because now the game will probably run too slow (20FPS or less)

Now, you can fix the slowness by changing a registry option in Windows. Make sure you've run the game at least once for the registry key to show up.

1) Run regedit.exe
2) Go to HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Windows NT/CurrentVersion/AppCompatFlags/Layers
3) You should see an entry for JK.EXE. Double click it to edit it.
4) Replace the entry currently in it with
"$ DWM8And16BitMitigation 8And16BitTimedPriSync 8And16BitAggregateBlts Layer_ForceDirectDrawEmulation"
(remove the quotes)

Note that this will disable the option to use Hardware Acceleration, so if a fix for it DOES appear in the future, you'll have to open this key again and remove the "Layer_ForceDirectDrawEmulation" flag.


Now that you've fixed the slowness, it will run too fast again. This time, you can fix it by getting a ddraw.dll that will cap the framerate. Get it here![bitpatch.com]

Unzip ddraw.dll and aqrit.cfg into your game folder. Now open up aqrit.cfg in a text editor.

Change the line FakeVsync to equal 1, and the line FakeVsyncInterval to equal 34.

Doing this will cap the game's framerate to 30. Sorry, but 60FPS just isn't possible in this game. For some reason Jedi Knight will try to keep the game's framerate at 30 even if it runs faster. However, the animations for your HUD will keep getting faster the higher your framerate is. Therefore, the ideal framerate for the game is 30FPS. You can use the lightsaber's altfire to make sure the speed is proper (compare in first and third person)

Again, Backbuffer In System Memory MUST be UNticked, or the framerate limiting won't actually slow down the HUD weapons' animations.


Q: "The game's got no music!"
A: This isn't a Windows 8 specific issue, it happens on all platforms. There are other threads that will help you get it back.


Q: "I have no HUD!"
A: Hit the minus key on your number row to get it back.
the :Last Star Fighters: league
http://www.starfighters.com/lsf
1997-2002

Last member left...

Return to “Jedi Knight & Mysteries of the Sith Troubleshooting Forum”

Who is online

Users browsing this forum: No registered users and 1 guest

cron